Site maintenance
Incident Report for OkCupid
Resolved
Maintenance is complete.
Posted over 2 years ago. Jan 06, 2015 - 05:47 EST
Investigating
The site is currently down for maintenance, we'll be back shortly!
Posted over 2 years ago. Jan 06, 2015 - 05:25 EST