EU Performance
Incident Report for OkCupid
Resolved
This incident has been resolved.
Posted about 4 years ago. Jun 16, 2014 - 21:50 EDT
Monitoring
Due to a problem with an upstream provider, performance in Europe may be degraded.
Posted about 4 years ago. Jun 16, 2014 - 14:20 EDT