Site down!
Incident Report for OkCupid
Resolved
The site is operational again.
Posted almost 2 years ago. Dec 08, 2015 - 15:37 EST
Identified
We are working on restoring service.
Posted almost 2 years ago. Dec 08, 2015 - 13:43 EST