EU Performance
Incident Report for OkCupid
Resolved
Service should be normal.
Posted about 3 years ago. Jun 29, 2014 - 18:09 EDT
Monitoring
Our upstream provider in the EU is experiencing problems, performance may be impacted.
Posted about 3 years ago. Jun 29, 2014 - 15:13 EDT